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Chapter 1. Linux Basics
Linux is inspired by the Unix operating system which first appeared in 1969, and has been in
continous use and development ever since. Many of the design conventions behind Unix also exist in
Linux and are central to understanding the basics of the system.
Unix was primarily oriented towards the command line interface, and that legacy is carried on in
Linux. Thus, the graphical user interface with its windows, icons and menus are built on top of a basic
command line interface. Furthermore, this means that the Linux file system is structured to be easily
manageable and accessible from the command line.
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1. Directories and File Systems
Linux and Unix file systems are organised in a hierarchical, tree-like structure. The highest level
of the file system is the / or root directory. In the Unix and Linux design philosophy, everything is
considered a file - including hard disks, partitions and removable media. This means that all other
files and directories (including other disks and partitions) exist under the root directory.
For example, /home/jebediah/cheeses.odt shows the correct full path to the cheeses.odt file that
exists in the jebediah directory which is under the home directory, which in turn, is under the root (/)
directory.
Underneath the root (/) directory, there is a set of important system directories that are common
across most Linux distributions that are used. The following is a listing of common directories that are
directly under the root (/) directory:
• /bin - important binary applications
• /boot - files that are required to boot the computer
• /dev - the device files
• /etc - configuration files, startup scripts, etc...
• /home - local users' home directories
• /lib - system libraries
• /lost+found - provides a lost+found system for files that exist under the root (/) directory
• /media - mounted (loaded) removable media such as CDs, digital cameras, etc...
• /mnt - mounted filesystems
• /opt - provides a location for optional applications to be installed
• /proc - special dynamic directory that maintains information about the state of the system,
including currently running processes
• /root - root user home directory, pronounced 'slash-root'
• /sbin - important system binaries
• /sys - contains information about the system
• /tmp - temporary files
• /usr - applications and files that are mostly available for all users to access
• /var - variable files such as logs and databases
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2. Permissions
All of the files on a Linux system have permissions that allow or prevent others from viewing,
modifying or executing. The super user "root" has the ability to access any file on the system. Each
file has access restrictions, user restrictions and have an owner/group association.
Every file is secured by the following three sets of permissions, in order of importance:
• user
applies to the user who is the owner of the file
• group
applies to the group that is associated with the file
• other
applies to all other users
Inside each of the three sets of permissions are the actual permissons. The permissions, along with the
way they apply differently to files and directories, are outlined below:
• read
files can be displayed/opened
directory contents can be displayed
• write
files can be edited or deleted
directory contents can be modified
• execute
executable files can be run as a program
directories can be entered
To view and edit the permissions on files and directories, open the Places → Home Folder and
right-click on a file or directory. Then select Properties. The permissions exist under the Permissions
tab and allow for the editing of all permission levels, if you are the owner of the file.
To learn more about file permissions in Linux, read the file permissions page
[https://help.ubuntu.com/community/FilePermissions] in the Ubuntu Wiki.
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3. Terminals
Working at the command line is not as daunting a task as you would think. There is no special
knowledge needed to know how to use the command line, it is a program like everything else. Most
things in Linux can be done using the command line, although there are graphical tools for most
programs, sometimes they are just not enough. This is where the command line comes in handy.
The terminal is often called the command prompt or the shell. In days gone by, this was the way the
user interacted with the computer, however Linux users have found that the use of the shell can be
quicker than a graphical method and still holds some merit today. Here you will learn how to use the
terminal.
The original use of the terminal was a file browser and indeed it is still used as a file browser, in the
event of the graphical environment failing. You can use the terminal as a file browser to navigate your
files and undo the changes that have been made.

3.1. Starting the Terminal
To start Terminal choose Applications → Accessories → Terminal .

3.2. Common Commands
View Directories - ls
The ls (LiSt) lists files in different colors with full formatted text
Create Directories - mkdir (directory name)
The mkdir (MaKeDIRectory) command will create a directory.
Change Directories - cd (/directory/location)
The cd (ChangeDirectory) command will change from your current directory to any directory you
specify.
Copy Files/Directories - cp (file or directory name) (to directory or filename)
The cp (CoPy) command will copy any files you specify. The cp -r command will copy any
directories you specify.
Remove Files/Directories - rm (file or directory name)
The rm (ReMove) command will delete any filename you specify. The rm -rf command will
remove any directory you specify.
Rename Files/Directories - mv (file or directory name)
The mv (MoVe) command will rename/move any file or directory you specify.
Find Files/Directories - locate (file or directory name)
The locate command will search your computer for any filename you specify. It uses an index of
the files on your system to work quickly: to update this index run the command updatedb. This
command is run automatically each day, if you leave your computer on. It needs to be run with
administrative privileges (see Chapter 2, Administrative Tasks [p. 8]
).
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You can also use wildcards to match one or more files, such as "*" (for all files) or "?" (to match one
character).
For a more thorough introduction to the Linux command line, please read the command line
introduction [https://help.ubuntu.com/community/BasicCommands] on the Ubuntu wiki.

3.3. Switch to Console mode
The usual method of command-line access in Ubuntu is to start a terminal (see Section 3.1, “Starting
the Terminal” [p. 4]
above) , however sometimes it is useful to switch to the real console:
1.

Use the Ctrl-Alt-F1 shortcut keys to switch to the first console.

2.

To switch back to Desktop mode, use the Ctrl-Alt-F7 shortcut keys.
There are six consoles available. Each one is accessible with the shortcut keys Ctrl-Alt-F1
to Ctrl-Alt-F6.

3.4. Disable the beep sound in Terminal mode
1.

Start a Terminal session, select: Applications → Accessories → Terminal from the desktop menu
system.

2.

Edit → Current Profile... . Select the General tab. Uncheck the Terminal bell checkbox.
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4. Text Editing
All of the configurations and settings in Linux are saved in text files. Even though you most often can
edit configurations through the graphical interface, you may occasionally have to edit them by hand.
Gedit is the default Ubuntu text editor, which you can launch by clicking Applications → Accessories
→ Text Editor on the desktop menu system.
At times in this guide, Gedit is run from the command line using gksudo, which runs Gedit with
administrative privileges, in order to modify configuration files.
If you need to use a text editor from the command line, you can use nano, which is a simple to use
text editor. When running it from the command line, always use the following command, which
ensures that the editor will not introduce line breaks:
nano -w

For more information about how to use nano, refer to the guide on the wiki
[https://help.ubuntu.com/community/NanoHowto].
There are also quite a few other terminal-based editors available in Ubuntu, popular ones include
VIM and Emacs (the pros and cons of each are cause for much friendly debate within the Linux
community). These are often more complex to use than nano, but are also more powerful.
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5. Users and Groups
To add users or groups to your system, you can use the Users And Groups application located in
System → Administration → Users and Groups .
Remember to log off and log back in order for the changes to become effective.

To add a new user, click on Add user, fill-in the data fields then click OK. To edit the properties of
each user, click the Properties button located in the main Users window.
To add a new group, select the Groups tab and click Add group. Choose a name for the new group
and, if you want, change the default value for the Group ID. If you try to allocate a Group ID that is in
use, the system will warn you.
You can add users to the newly created group by selecting a user from the left menu and clicking on
the Add button. Removing a user is as simple as adding one: select a user from the right menu then
click Remove. When you are ready, click OK and the new group with its users, if inserted, will be
created.
To edit the properties of a group, from within the Groups main window, choose a group name and
click on the Properties button.
To remove a user or a group from the system, select the user or group you want to delete and click
Delete.
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In Ubuntu, for security reasons, administrative tasks are confined to users with special privileges.
Administrative access is given to individual users, who may use the sudo command to perform
administrative tasks. The first user account you created on your system during installation will, by
default, have access to sudo. You can restrict and enable sudo access to users with the Users and
Groups application (see Section 5, “Users and Groups” [p. 7] for more information).
When you run an application that requires root privileges, sudo will ask you to input your normal user
password. This ensures that rogue applications cannot damage your system, and serves as a reminder
that you are about to perform administrative actions which require you to be careful!
To use sudo when using the command line, simply type "sudo" before the command you wish to run.
Sudo will then prompt you for your password.
Sudo will remember your password for a set amount of time, which by default is 15 minutes, but can
be changed. This feature was designed to allow users to perform multiple administrative tasks without
being asked for a password each time.
Be careful when doing administrative tasks, you might damage your system!

Some other tips on using sudo:
• To use a "root" terminal, type "sudo -i" at the command line.
• All of the default graphical configuration tools in Ubuntu already use sudo, so they will prompt you
for your password if needed.
• For more information on the sudo program and the absence of a root user in Ubuntu, read the sudo
page [https://help.ubuntu.com/community/RootSudo] on the Ubuntu wiki.
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1. What is a package manager?
To add or remove applications in Ubuntu, you need to use a package manager. This is a program that
installs and uninstalls software, and keeps track of all the components each piece of software needs.
There are three main package managers you can use in Ubuntu:
• Add/Remove Programs - The easiest way to install and uninstall programs.
• Synaptic - Advanced control of software and other system components.
• Apt - For if you prefer using the Terminal.
If you open more than one of these programs at once, they may not work. Close them all and open just
one.
You need administrative access to use any of these programs.
• Chapter 2, Administrative Tasks [p. 8]
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2. Add/Remove Applications
With the Add/Remove… item in the Applications menu, you can install programs to do new things
with Ubuntu. You can also remove programs you don’t want. You need administrative access to use
Add/Remove Programs.
• Chapter 2, Administrative Tasks [p. 8]
If you know the name of a program you want to install, enter it in the Search field. Otherwise, begin
by choosing a software category on the left.
Programs that are already installed begin with a check mark next to their name. Uncheck a program if
you want to remove it from your computer.
When you click Apply or OK, any new software will be downloaded from the Internet, and Ubuntu
will make the changes you selected. If you have not activated the online package archive, you may be
asked to insert your Ubuntu CD-ROM to install some packages.
Some software cannot be installed or removed using Add/Remove Applications. If you cannot find
the package you are looking for, click Advanced to open Synaptic.
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3. Synaptic Package Manager
Synaptic is an advanced package management application that can install and remove every package
available to your system. The interface is graphical like Add/Remove Applications, but presents much
more information and gives you complete control over the software on your computer.
To launch Synaptic, from the System menu choose Administration → Synaptic Package Manager.
You need administrative access to use Synaptic.
• Chapter 2, Administrative Tasks [p. 8]
If you know the name of the package you want to install or remove, click the Search button, and
enter the package name or a short search term. You can also search for packages by description (for
example, you can find all packages mentioning “arcade” or “mathematics”).
Use the categories on the left to filter the list of packages. To return to the list of categories after doing
a search, click Sections.
To install a package, click the box next to it and choose Mark for installation. If you change your
mind, choose Unmark. To remove a package that is already installed, choose Mark for Removal.
When you’ve finished, click Apply and Ubuntu will make the changes you selected. If you don’t want
to make any changes, close the window instead.
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4. Command-Line Package Management With APT
If you are comfortable using the Terminal, you can use apt (Advanced Packaging Tool) to install or
remove software. You need administrative access to use apt.
• Chapter 2, Administrative Tasks [p. 8]
To update the local list of packages, enter in a Terminal:
sudo apt-get update

To install all available updates:
sudo apt-get upgrade

To install a package:
sudo apt-get install package

To remove a package:
sudo apt-get remove package

To list other apt commands and options:
apt-get help

For more information, see Debian’s apt manual
[http://www.debian.org/doc/user-manuals#apt-howto].

13

Adding, Removing and Updating Applications

5. Installing a Single Package File
The preferred method of installing programs is via the package managers described in this chapter.
However, although the Ubuntu package archives are very large, it is possible that you may wish to
install a package that is not available in the Ubuntu archives. If this happens, you can also download
and install files from websites.
It is important to ensure that any files you download come from a safe source before
installing them.
There are many different kinds of Linux package files. Most of these are associated with the package
managers of specific Linux distributions. Examples are Debian Package files (.deb files), RPM
Package Manager files (.rpm files), and Tarballs (.tar files).
This section deals with installing these single files.
It is not guaranteed that these files will be compatible with your system and you will not
receive security updates if you install these files. For these reasons, if you wish to install a
program, always use a native Ubuntu package of the application available through a package
manager, if there is one available.

5.1. Install/uninstall .deb files
These files are Debian packages. The package files associated with Ubuntu have the .deb suffix
because of Ubuntu's close relations with the Debian GNU/Linux distribution. You will need
administrative privileges to install a .deb file (see Chapter 2, Administrative Tasks [p. 8]).
To install a .deb file, double-click on it. If you prefer using the Terminal, enter:
sudo dpkg -i package_file.deb

To uninstall a .deb file, deselect it in your package manager. Or from a Terminal, enter:
sudo dpkg -r package_name

5.2. Convert .rpm files to .deb files
Another type of package files is Red Hat Package Manager files which have the .rpm suffix. It is not
recommended to install these on an Ubuntu system. In almost all cases, a native Ubuntu .deb package
is available. However, if absolutely necessary, an .rpm file can be converted to a .deb package using
the program alien.
In a terminal, enter:
sudo alien package_file.rpm

If you get a “command not found” or similar error, install alien before trying again:
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sudo apt-get install alien

5.3. Install tarballs
Files with the .tar.gz or .tar.bz2 suffix are package files known as tarballs which are widely used in
Linux and Unix.
If there is no native Ubuntu package available in any of the Ubuntu repositories, you can use the
command line to install or uninstall the Tarball file by following the instructions that come with the
package.
Tarballs often contain the source code of the program, and need to be compiled in order to be used. To
do this, extra software will generally be needed (see Section 1, “Basic Compilers” [p. 62]
).
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6. Software Repositories
6.1. What are Repositories?
There are thousands of programs available to install on Ubuntu. These programs are stored in
software archives (repositories) and are made freely available for installation over the Internet. This
makes it very easy to install new programs in Linux, and it is also very secure, because each program
you install is built specially for Ubuntu and checked before it is installed. To organise the software,
Ubuntu repositories are categorised into four groups: Main, Restricted, Universe, and Multiverse.
The rationale used to determine which software goes into which category is based on two factors:
• The level of support software development teams provide for a program.
• The level of compliance the program has to the Free Software Philosophy
[http://www.ubuntu.com/ubuntu/philosophy].
You can find more information about the Repositories available on the website
[http://www.ubuntu.com/ubuntu/components].
The standard Ubuntu Install CD contains some software from the Main and Restricted categories.
Once your system is made aware of the Internet-based locations for these repositories, many more
software programs are made available for installation. Using the software package management tools
already installed on your system, you can search for, install and update any piece of software directly
over the Internet, without the need for the CD.

6.2. Adding Extra Repositories
To install software from the “Universe” or “Multiverse” repositories:
1.

Open System → Administration → Software Properties .

2.

Select Add

3.

To use the “Universe” repository, turn on Community Maintained (Universe).
Adding this repository will mean that the majority of the Free Software universe will be
available to install on your system. This software is supported by a carefully selected
group of volunteers within the Ubuntu Community, but is not supported by the core
Ubuntu development team and may not include security updates.

4.

To use the “Multiverse” repository, turn on Non-free (Multiverse).
Adding this repository will mean that software which has been classified as non-free
will be available to install on your system. This software may not be permitted in some
jurisdictions. When installing each package from this repository, you should verify
that the laws of your country permit you to use it. Again, this software may not include
security updates.

5.

Click Close to save your changes and exit.
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7. Updates
Sometimes the Ubuntu developers release feature and security updates for applications and packages
within the Ubuntu system.
When these updates are available, Ubuntu will inform you with a pop-up and a red icon in your
notification area. To update your system, click the red button, enter your password and click OK.
The Update Manager program will list the available updates: to download and install these updates
click Install Updates. Ubuntu will then download and install the available updates from the Internet.
When Update Manager has finished updating your system, close the pop-up window with the Close
button, then close Update Manager to finish updating your system.
After installing some important updates, it may be necessary to restart your computer. If so,
Ubuntu will inform you with a popup and an icon in your notification area.
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This section describes the music and video players available to use with Ubuntu and how to configure
them to listen to different types of multimedia files.
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1. Playing and Organising Music Files
To play and organize your music, Ubuntu comes with#Rhythmbox Music Player, which looks similar
to iTunes. When you first start Rhythmbox, it will scan your home directory for any supported music
files you have and add it to the database. To start Rhythmbox, choose Applications → Sound & Video
→ Rhythmbox Music Player .
Ubuntu does not directly support the MP3 format, because it is restricted by patents and proprietary
rights. Instead Ubuntu supports the Ogg Vorbis format out of the box, a completely free, open and
non-patented format. Ogg Vorbis files also sound better then MP3 files of the same file size and are
supported by many portable music players.
• Players that work with Vorbis [http://wiki.xiph.org/index.php/PortablePlayers]
You can still play your old MP3 files by installing MP3 support (see Section 5, “Multimedia
Codecs” [p. 23]
). Instructions for other formats, such as Windows Media Audio
(wma/wmv) and other patent-encumbered formats can be found on the Ubuntu Wiki
[http://wiki.ubuntu.com/RestrictedFormats].
The Cowbell ID3 tag editor can edit the metadata on your mp3 and other music files. To use Cowbell:
1.

Install the cowbell package from the “Universe” repository (see Chapter 3, Adding, Removing
and Updating Applications [p. 9]);

2.

To run Cowbell, choose Applications → Sound & Video → Cowbell Music Organizer.
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2. Playing and Extracting Audio CDs
When you insert an audio CD, the Sound Juicer CD player and ripper opens automatically. To play
the CD, click the Play button or press Ctrl-P. To play a particular track, double-click on the track or
select the track and click Play.
To extract (rip) your audio CD, make sure the tracks that you want to rip are selected, then click the
Extract button or press Ctrl-Enter.
If you are connected to the internet, Sound Juicer will retrieve the CD artist, title, and track
data from MusicBrainz.org [http://musicbrainz.org], a community-maintained database of
over 360,000 albums.
To start Sound Juicer manually, choose Applications → Sound & Video → Sound Juicer CD
Extractor.
You can use the preferences window to control where the extracted audio files are stored on your
computer, the filename of extracted audio files, and the file format and codec used for the files. In the
main window, choose Edit → Preferences.
Sound Juicer can extract audio files to these formats:
• Ogg Vorbis - A patent-free lossy audio compression format, which typically produces higher
quality and greater compression than MP3.
• More about Vorbis from vorbis.com [http://vorbis.com/faq/]
• FLAC - The Free Lossless Audio Codec. It can compress audio files up to 50% without removing
any information from the audio stream.
• FLAC Web site [http://flac.sourceforge.net/]
• WAV - Typically used for voice recordings. Sound Juicer uses this format for low quality mono
audio files.
You can also extract CD audio files to the proprietary non-free MP3 format. Instructions on how to
rip to the MP3 format are in the help for Sound Juicer. Choose Help → Contents and navigate to the
Preferences section.
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3. Burning CDs
When you put a blank CD in the drive Ubuntu will ask if you want to burn an audio or data CD.
Clicking on Burn Audio CD will launch Serpentine . To add music to your audio CD, either drag
music from your File Browser or use the Add button. You will also need to select the size of your CD
(21, 74, 80 or 90 minutes). Serpentine will warn you if you exceed the set limit.
To make a photo or data CD, click Burn Data CD. Ubuntu will open a CD/DVD Creator window.
The CD Creator is built into the File Browser, and it allows you to add any file or folder you have
permission to access. When you are ready to burn the CD, click Write to Disc. Ubuntu will then
prompt you to select the drive containing the blank CD, and give you the opportunity to name the CD
and select the write speed. Finally, click Write to create the new photo or data CD.
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4. Video Playback
To play video, Ubuntu comes with Totem Movie Player, which looks and functions similar to
Windows Media Player. Features of Totem include custom playlists and DVD playback. You can start
Totem by clicking: Applications → Sound & Video → Movie Player from the desktop menu system.
To read video files, Totem uses the Gstreamer framework. To play some video formats, you may need
to add further codec support (see Section 5, “Multimedia Codecs” [p. 23]
).
There are also other multimedia applications available. Examples include Mplayer, Xine and
Totem-xine (which uses the Xine framework, instead of the Gstreamer framework). You may benefit
from trying alternative video players.
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5. Multimedia Codecs
Many applications in Ubuntu use the GStreamer open source multimedia framework. The codec
plugins for GStreamer are organised in different packages depending on the licensing that applies
to the various codecs. You can see which codecs are contained in which plugin on the GStreamer
website [http://gstreamer.freedesktop.org/documentation/plugins.html].
Other applications, such as Mplayer and Xine, do not use the Gstreamer framework.
Due to patent and copyright restrictions, codecs for these programs are not included
at all in Ubuntu. For more information on these read the Restricted Formats
[https://help.ubuntu.com/community/RestrictedFormats] wiki page.
To install extra codecs for Gstreamer:
•

Install the following packages from the “Universe” and “Multiverse” repositories (see Chapter 3,
Adding, Removing and Updating Applications [p. 9]):
gstreamer0.10-plugins-ugly
gstreamer0.10-plugins-ugly-multiverse
gstreamer0.10-plugins-bad
gstreamer0.10-plugins-bad-multiverse
gstreamer0.10-ffmpeg

You will need to use Synaptic Package Manager to install these packages.

Some of these packages may not be permitted in some countries: you should verify that
you are permitted to use them before installing them.
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6. Using an iPod
You can play music directly off an iPod with Rhythmbox Music Player. Plug the iPod into the
computer, and open Rhythmbox.
To transfer music files to and from an iPod, you can use gtkpod:
1.

Install the gtkpod package from the “Universe” repository (see Chapter 3, Adding, Removing and
Updating Applications [p. 9]).

2.

To run gtkpod, choose Applications → Sound & Video → gtkpod.

24

Music and Video

7. Editing Audio Files
Audacity is free, open source software for recording and editing sounds. To use Audacity:
1.

Install the audacity package from the “Universe” repository (see Chapter 3, Adding, Removing
and Updating Applications [p. 9]).

2.

To run Audacity, choose Applications → Sound & Video → Audacity.

3.

For further help with Audacity, use Audacity’s Help menu.
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8. DVD Playback
The movie players provided in Ubuntu are capable of reading DVDs that are not encrypted. However,
most commercial DVDs are encrypted with CSS (the Content Scrambling System) and currently for
legal reasons it is not possible to include support for these DVDs in Ubuntu. However it is possible to
enable support as follows:
The legal status of this library is not fully clear. In some countries it is possible that the use
of this library to play or copy DVDs is not permitted by law. Verify that you are within your
rights in using it.
1.

Install the libdvdread3 package (see Chapter 3, Adding, Removing and Updating Applications [p.
9]).
You will need to use Synaptic Package Manager to install this package

2.

To activate DVD decryption, type the following line into a terminal prompt:
sudo /usr/share/doc/libdvdread3/install-css.sh

3.

To play DVDs with Totem, you will need to install some extra codecs (see Section 5,
“Multimedia Codecs” [p. 23]).

4.

However, the Gstreamer framework (used by Totem) does not support menus or subtitles for
DVD playback. For this reason, you can install a separate DVD player, Xine, which supports
these. To install Xine, install the gxine package from the “Universe” repository (see Chapter 3,
Adding, Removing and Updating Applications [p. 9]).

5.

You can then open gxine from the Sound & Video menu.
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9. Backing Up DVDs
You can back up your DVDs to files or onto DVD+/- discs with DVD::RIP. To install DVD::RIP:
Before backing up a DVD, you must ensure that you are legally permitted to make copies of
it.
1.

Install the Multimedia Codecs (see Section 5, “Multimedia Codecs” [p. 23]).

2.

Enable DVD video playback (see Section 8, “DVD Playback” [p. 26]).

3.

Install dvdrip and transcode from the “Multiverse” repository (see Chapter 3, Adding, Removing
and Updating Applications [p. 9]).

4.

You can run the program using the command dvdrip (see the run application manual
[ghelp:user-guide#tools-run-app] for help on how to run an application without using
the menu). If you wish, you can add a menu entry for the program dvdrip (see the menu
editor manual [ghelp:user-guide#menu-editor] for help on how to add menu entries).
We recommend you enter it in the Sound & Video menu, and that you use the file
/usr/share/perl5/Video/DVDRip/icon.xpm for the icon.

5.

To start dvd::rip, choose Applications → Sound & Video → dvd::rip.
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10. RealPlayer
1.

Install the realplay package from the Commercial repository (see Chapter 3, Adding, Removing
and Updating Applications [p. 9]).

2.

To run RealPlayer, choose Applications → Sound & Video → RealPlayer 10.
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11. Video Editing
Kino is an advanced video editor. It features excellent integration with IEEE-1394 for capture, VTR
control, and recording back to the camera. It captures video to disk in Raw DV and AVI format, in
both type-1 DV and type-2 DV (separate audio stream) encodings. For more information, see the Kino
website [http://www.kinodv.org/article/static/2]. To use it:
1.

Install the kino package (see Chapter 3, Adding, Removing and Updating Applications [p. 9]).

2.

To run Kino, choose Applications → Sound & Video → Kino Video Editor.

You can also try the PiTiVi video editor by installing the pitivi package from the “Universe”
repository (see Chapter 3, Adding, Removing and Updating Applications [p. 9]). PiTiVi is a video
editor for the GNOME desktop. It is still in fairly early development, but worth a try.
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Chapter 5. Internet
This section describes a number of tasks related to the internet, including how to connect to the
internet, configuring and using an internet browser, and using other types of internet programs.
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1. Connecting to the Internet
1.1. Basic Procedure
This section describes the basic procedure for connecting to the internet.
If you have a wireless connection, or connect to the internet through a modem (including
an ADSL modem), and this section does not work, you should read Section 1.2, “Wireless
Cards” [p. 31]
or Section 1.3, “ADSL Connections” [p. 33]
.
To connect to the internet:
1.

Open System → Administration → Networking.

2.

Select the connection you wish to use, then click Properties.

3.

Ensure Enable this connection is turned on.

4.

If your ISP or network administrator has given you an IP address, set Configuration to Static IP
address, then enter the address in the IP address field and click OK. Otherwise, set Configuration
to DHCP and click OK.

5.

To activate or deactivate network connections, select your connection, then click
Activate/Deactivate.

1.2. Wireless Cards
Many wireless cards are automatically detected by Ubuntu during installation. To see if your
card is supported, open System → Administration → Networking. If your wireless card is
listed, you can follow Section 1.1, “Basic Procedure” [p. 31]
to connect to the internet. A
complete listing of wireless cards which work with Ubuntu can be found online at the Ubuntu Wiki
[https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported]. Please add your wireless
card to the list if it works with Ubuntu.
Some cards may not work automatically with Ubuntu. If this is the case, please look at the Wireless
Troubleshooting Guide [https://wiki.ubuntu.com/WirelessTroubleshootingGuide] on the Ubuntu Wiki
which is an excellent resource for troubleshooting wireless cards.
If your wireless card does not work with Ubuntu, you may have to do some research in order to
activate it. A good way of getting a wireless card to work is to use the ndiswrapper tool which allows
Ubuntu to use the Microsoft Windows driver for the wireless card. To do this, follow the instructions
below in Section 1.2.1, “Windows Wireless Drivers” [p. 32]
.
All other information regarding wireless networking on Ubuntu is collected at Wireless Networking
Central [https://help.ubuntu.com/community/WifiDocs] on the Ubuntu Wiki.
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1.2.1. Windows Wireless Drivers
Even if your wireless network card does not have a native Linux driver, you may still be able to get it
working with ndiswrapper. Ndiswrapper is a Linux module which allows Ubuntu to use the Windows
driver for wireless cards (in most cases).
These instructions apply only to the x86 and AMD64 versions of Ubuntu, and not to Ubuntu
for Power PC (PPC).
If you have access to the internet, you can see if your wireless cards is
in the list of cards supported by ndiswrapper on the ndiswrapper website
[http://ndiswrapper.sourceforge.net/mediawiki/index.php/List].
To install ndiswrapper, install the package ndiswrapper-utils (see Chapter 3, Adding, Removing and
Updating Applications [p. 9]). This package is provided on the Ubuntu CD. If you have access to the
internet, you can also optionally install a graphical tool, ndisgtk from the Universe repository (see
ghelp:add-applications#extra-repositories).
In order to set up ndiswrapper, it is necessary to obtain the Windows driver for your wireless card.
Generally, the best way to do this is from the CD supplied with your wireless card. You should
copy two files to the same place on your computer, one ending in .SYS and one ending in .INF. If
you find any files which end in .BIN, also copy those. If you are not able to find the right files, and
have alternative access to the internet, you may be able to obtain help from the ndiswrapper website
[http://ndiswrapper.sourceforge.net/mediawiki/index.php/list].
If you have installed the graphical tool ndisgtk, to set up ndiswrapper, simply select System →
Administration → Windows Wireless Drivers from the menu, and follow the instructions given.
If you have not installed the graphical tool, use this procedure:
1.

Open Applications → Accessories → Terminal and type:
sudo ndiswrapper -i ~/Desktop/drivername.inf

The above command assumes that your .INF file is named drivername.inf and was
copied to your Desktop. Replace these values if necessary.
2.

To check if it is working correctly, type:
ndiswrapper -l

If it is working correctly, you should see:

Installed ndis drivers:
{name of driver}

3.

driver present, hardware present

For ndiswrapper to function, you need to load a module. To do this, type:
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sudo depmod -a
sudo modprobe ndiswrapper

4.

To ensure that the module is loaded each time you boot the computer, type:
sudo ndiswrapper -m

You should now be able to connect to the internet by following the instructions at Section 1.1, “Basic
Procedure” [p. 31]
.

1.3. ADSL Connections
All PPPOE and router-style ADSL modems that use an Ethernet connection are supported by Ubuntu,
and some USB ADSL modems are supported too.
For a router-style ADSL modem, simply follow Section 1.1, “Basic Procedure” [p. 31]
For information on setting up a PPPOE ADSL modem see Section 1.3.1, “PPPoE Modems” [p.
33]
.
For information on setting up a USB ADSL modem see Section 1.3.2, “USB ADSL Modems” [p.
34]
.
1.3.1. PPPoE Modems
This section is about setting up an ADSL Internet connection using an ethernet PPPoE modem.
You will need to have subscribed to an Internet Service Provider, and your Internet connection
must be installed and functional. A "DSL" light on your modem usually shows that the line is
synchronized.
You will need your username and password for the account. You must also have an ethernet card
connected to your PPPoE modem with the correct type of cable.
Finally, you need the PPPoE package to be installed in order for the following command to work.
This package is installed by default, but can be missing if the configuration has been changed. If the
following command does not work, you will need to install this package, which can be found on the
Ubuntu CD.
To set up the modem:
1.

Open Applications → Accessories → Terminal

2.

In the terminal type:
sudo pppoeconf

3.

A text-based menu program will guide you through the next steps, which are:
1. Confirm that your Ethernet card is detected.
2. Enter your username.
3. Enter your password.
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4. If you already have a PPPoE Connection configured, you will be asked if it may be modified.
5. Popular options: you are asked if you want the 'noauth' and 'defaultroute' options and to
remove 'nodetach' - choose "Yes".
6. Use peer DNS - choose "Yes".
7. Limited MSS problem - choose "Yes".
8. When you are asked if you want to connect at start up, you will probably want to say yes.
9. Finally you are asked if you want to establish the connection immediately.
4.

Once you have finished these steps, your connection should be working.

To start your ADSL connection on demand, in a terminal type:
sudo pon dsl-provider

To stop your ADSL connection, in a terminal type:
sudo poff dsl-provider

1.3.2. USB ADSL Modems
Often parts of ADSL USB modem drivers are proprietary, closed source software, with a restrictive
licence, and so the whole driver cannot be supplied with Ubuntu. To get a modem to work with these
drivers, you will need to download files from Internet with a computer having a working connection,
then transfer the downloaded files to you Ubuntu installation.
USB is far from the ideal medium for network access, if you have a modem that can connect
both via USB and ethernet or a ethernet router, you should use the ethernet connection
instead of the USB modem.
Since any USB modem installation will require Internet access to download the necessary proprietary
drivers, as well as extensive configuration which is beyond the scope of this guide, all we can do here
is to list the USB Modem models known to work with Ubuntu with links to the relevant installation
instructions on the Ubuntu community help site.
The installation procedure of USB modems differs depending on the specific make and model of your
modem. To identify model of your modem, Note the name and number on the front. Occasionaly you
may have to look for a label to discover the exact model. Consult the list below to see which driver
your modem requires and note the link.
When you go online to download the necessary drivers, you can access the relevant driver download
links from the page with the installation instructions relevant to that model of USB modem.
1. Speedtouch modems:
https://help.ubuntu.com/community/UsbAdslModem/SpeedTouch
2. Modems using the Analog Devices Inc. eagle-usb I, II or III chipset (such as Sagem Fast 800,
Comtrend ct 350 etc.):
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https://help.ubuntu.com/community/UsbAdslModem/ueagle-atm
https://help.ubuntu.com/community/UsbAdslModem/EagleUsb
3. Connexant AccessRunner based modems:
https://help.ubuntu.com/community/UsbAdslModem/EciAdsl
https://help.ubuntu.com/community/UsbAdslModem/AccessRunner
https://help.ubuntu.com/community/UsbAdslModem/e-techV2

1.4. Dialup Modems
Most dialup modems are not supported by Ubuntu, but drivers can be found that will enable the use of
such modems. First you need to identify what chipset your dialup modem is using:

wget -c http://linmodems.technion.ac.il/packages/scanModem.gz
gunzip -c scanModem.gz > scanModem
chmod +x scanModem
sudo ./scanModem
gedit Modem/ModemData.txt

Read this file, it should list what modem chipset you have. Once you are aware of the chipset you
have, see http://www.linmodems.org/ and follow the directions for your modem. More infomation can
be found at SettingUpModems [https://wiki.ubuntu.com/SettingUpModems] on the Ubuntu Wiki.
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2. Web browsing
The powerful and secure Mozilla Firefox web browser is included in Ubuntu. Firefox features tabbed
browsing, pop-up blocking, built-in search, and live bookmarks. Also supported are popular plug-ins
such as Java, Macromedia Flash, and RealPlayer. Firefox can be launched by clicking Applications →
Internet → Firefox .

2.1. Viewing Online Audio and Video in Firefox
To view online audio and video streams in Firefox, you may need to install some plugins. Which
plugin you choose to install depends on which media player you prefer (see Section 4, “Video
Playback” [p. 22]).
1.

For the Totem Gstreamer plugin (the default Ubuntu media player), install the
totem-gstreamer-firefox-plugin package from the “Universe” repository (see Chapter 3, Adding,
Removing and Updating Applications [p. 9]).

2.

For the Totem Xine plugin, install the totem-xine-firefox-plugin package from the “Universe”
repository (see Chapter 3, Adding, Removing and Updating Applications [p. 9]).

3.

For the Mplayer plugin, install the mozilla-mplayer package from the “Multiverse” repository
(see Chapter 3, Adding, Removing and Updating Applications [p. 9]).

4.

The changes will take effect when you close and open Firefox.
These steps will install the plugin for Firefox. However, to play some formats, you may
need to add some extra codecs (see Section 5, “Multimedia Codecs” [p. 23]).

2.2. Macromedia Flash for Firefox
To view flash graphics from the Mozilla Firefox web browser:
1.

Install the flashplugin-nonfree package from the “Multiverse” repository (see Chapter 3, Adding,
Removing and Updating Applications [p. 9]).

2.

The plug-in will be available the next time you start Firefox.
Installing the package as described above will download and install the plugin. You need an
internet connection for this to work. If, after installing the application, you need to download
and install the plugin at a later time, enter the following command in a terminal:
sudo update-flashplugin

2.3. Java plugin for Mozilla Firefox
Some websites require the Java plugin for Mozilla Firefox. The easiest way to view Java applets is to
install the j2re1.4-mozilla-plugin package from the “Multiverse” repository.
For a more complete Java installation, see Section 2, “Java Runtime Environment (1.5)” [p. 63]
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2.4. NVU Web Authoring System
NVU is a WYSIWYG (What You See Is What You Get) graphical web design application, similar to
Dreamweaver.
1.

Install the nvu package from the “Universe” repository (see Chapter 3, Adding, Removing and
Updating Applications [p. 9]).

2.

To start Nvu, choose Applications → Office → Nvu .

2.5. Bluefish Web Development Studio
Bluefish is a powerful editor for web designers and programmers. Bluefish supports many
programming and markup languages, and includes many utilities for designers and programmers.
1.

Install the bluefish package from the “Universe” repository (see Chapter 3, Adding, Removing
and Updating Applications [p. 9]).

2.

To start Bluefish, choose Applications → Programming → Bluefish Editor
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3. Email
3.1. Evolution Mail
The Evolution groupware suite can handle all your email, contact lists, tasks and calendar needs. It
also can act as a newsreader and also integrates with the Gnome panel clock, giving you one-click
access to your task list.
Evolution can be launched by clicking Applications → Internet → Evolution Mail from the desktop
menu system.
If you have Evolution installed, you can find a guide to using it in the internet section
[x-yelp-toc:#ApplicationsInternet] of this help.

3.2. Alternative Email Clients
You can also use Mozilla Thunderbird for email. To install it, install the mozilla-thunderbird package
(see Chapter 3, Adding, Removing and Updating Applications [p. 9]).
To start Thunderbird, choose Applications → Internet → Thunderbird Mail Client.
To change your preferred email client to Mozilla Thunderbird:
1.

Choose System → Preferences → Preferred Applications

2.

Click on the Mail Reader tab, and select the Custom option.

3.

In the Command text box, type mozilla-thunderbird %s, then close the dialog.

38

Internet

4. Instant Messaging
4.1. Gaim
Gaim is the default instant messenger client in Ubuntu. With Gaim you can talk to people who use
AIM/ICQ, Gadu-Gadu, GroupWise, IRC, Jabber, MSN, Napster and Yahoo, and list all your buddies
in a single window.
To start Gaim, choose Applications → Internet → Gaim Internet Messenger .

4.2. XChat-GNOME
XChat-GNOME is an advanced, graphical, multi-platform Internet Relay Chat (IRC) client. Its
features include advanced scripting support (perl and python) and a clean, easy to use interface.
1.

Install the xchat-gnome package from the main repository (see Chapter 3, Adding, Removing and
Updating Applications [p. 9]).

2.

To start XChat-GNOME, choose Applications → Internet → Xchat-GNOME IRC Chat .

4.2.1. Joining #ubuntu with XChat-Gnome
One excellent way to get help with Ubuntu or introduce yourself to IRC is to join Ubuntu's official
support channel on Freenode.
1.

Start XChat-Gnome as above.

2.

When you start XChat-Gnome for the first time, it will ask you for an IRC Nickname & your real
name. Pick anything you want for your nick (first initial & your last name is good, or be more
creative), put your real name or part of it, and press OK.

3.

In the Server Window that opens next, select Ubuntu Servers, and press Connect.
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5. Peer To Peer
5.1. BitTorrent
BitTorrent capability is included in Ubuntu by default. Find a BitTorrent .torrent file online, click on
it in Firefox, and the Gnome BitTorrent client should start automatically.
To restart a download from a .torrent file that is already on your computer, double-click on it.

5.2. aMule File Sharing Client
1.

Install the amule package from the “Universe” repository (see Chapter 3, Adding, Removing and
Updating Applications [p. 9]).

2.

To open aMule, choose Applications → Internet → aMule .
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6. News Readers
6.1. Pan News Reader
1.

Install the pan package (see Chapter 3, Adding, Removing and Updating Applications [p. 9]).

2.

To open Pan Newsreader, choose Applications → Internet → Pan Newsreader.

6.2. Liferea News Reader
1.

Install the liferea package from the “Universe” repository (see Chapter 3, Adding, Removing and
Updating Applications [p. 9]).

2.

To open Liferea Feed Reader, choose Applications → Internet → Liferea Feed Reader.
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7. Networking
7.1. Change the Computer Name
1.

Open System → Administration → Networking .

2.

Click General, and enter the name of the computer in the Hostname field.

Restart the computer for the change to take effect.

7.2. Networking Utilities
7.2.1. Firestarter Firewall
A firewall protects a computer system from unauthorized access. It is not normally necessary to
install a firewall on an Ubuntu system, because access to the system is closed by default. However,
if you run any services that let other computers access yours (for example, the Apache web server),
it is advisable to install a firewall. Firestarter is a program that lets you control a firewall through a
graphical interface.
1.

Install the Firestarter package from the “Universe” repository (see Chapter 3, Adding, Removing
and Updating Applications [p. 9]).

2.

After it is installed, run Applications → System Tools → Firestarter to configure your firewall.
The firewall will now start in the background when your computer starts.

7.2.2. Graphical Network Monitor
Etherape displays network activity among different hosts using circles of varying size.
1.

Install the etherape package from the “Universe” repository (see Chapter 3, Adding, Removing
and Updating Applications [p. 9]).

2.

Choose: Applications → Internet → Etherape

7.2.3. Network Traffic Analyzer
Ethereal is a network traffic analyzer/sniffer that captures packets off the network in real time and
displays their contents.
1.

Install the ethereal package from the “Universe” repository (see Chapter 3, Adding, Removing
and Updating Applications [p. 9]).

2.

Choose: Applications → Internet → Ethereal

7.3. Browse Network Computers
To view computers on the network, open Places → Network Servers.
You may need to enter a username, password, and domain. You should obtain these from your
network administrator.
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Chapter 6. Office
Ubuntu comes with a variety of software for performing office tasks — word processing and
publishing, spreadsheets, and presentations.
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1. OpenOffice.org
Ubuntu comes with OpenOffice.org, an office suite that includes a powerful word processor,
spreadsheet, presentation designer, and database management. The suite has excellent compatibility
with other major office suites, such as Microsoft Office.
• OpenOffice.org Web site [http://www.openoffice.org/]
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2. GNOME Office
The GNOME desktop features a separate office suite. These programs are generally lighter and faster
than the programs in the OpenOffice.org suite, and have fewer features as a result. But this may be
exactly what you want. The Suite has excellent compatibility with other major Office suites, such as
Microsoft Office.
The GNOME Office Suite includes the following software:
• A word processor (Abiword);
• A spreadsheet (Gnumeric);
• A database management program (GNOME-DB);
• A diagram editor (Dia);
• Two graphics applications (Inkscape and The GIMP); and
• A project management application (Planner).
Each of these applications can also be installed separately.

To install the GNOME Office suite:
1.

Install the gnome-office package from the “Universe” repository (see Chapter 3, Adding,
Removing and Updating Applications [p. 9]).

2.

The Office applications can then be found in the menu at Applications → Office, and the
Graphics applications can be found at Applications → Graphics.
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3. GnuCash Accounting Application
GnuCash is a program to manage your personal or business finances. GnuCash lets you track bank
accounts, stocks, income and expenses. As quick and intuitive as a checkbook register, it is based on
professional accounting principles to ensure balanced books and accurate reports.
• GnuCash Web site [http://gnucash.org/]
To use GnuCash:
1.

Install the gnucash package from the “Universe” repository (see Chapter 3, Adding, Removing
and Updating Applications [p. 9]).

2.

You can open GnuCash by running the command gnucash (see the run application manual
[ghelp:user-guide#tools-run-app] for help on how to run an application without using the menu).
If you wish, you can add a menu entry for the program gnucash (see the menu editor manual
[ghelp:user-guide#menu-editor] for help on how to add menu entries).
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4. Scribus Desktop Publishing Application
Scribus is a professional desktop publishing program. For more information, see the Scribus website
[http://www.scribus.org.uk/].
1.

Install the scribus package (see Chapter 3, Adding, Removing and Updating Applications [p. 9]).

2.

To install additional templates, install the scribus-template package from the “Universe”
repository (see Chapter 3, Adding, Removing and Updating Applications [p. 9]).
You will need to use Synaptic Package Manager to install this package

3.

To start Scribus, choose Applications → Office → Scribus .
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Chapter 7. Graphics & Photos
This section describes the photo management and graphic design applications available to use with
Ubuntu, and describes how to set up 3d graphics devices.
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1. Digital Cameras
Ubuntu detects most USB digital cameras automatically. Plug in and switch on the camera, and
Ubuntu will then ask you if you would like to import the photos it contains. Click on Import, and
Ubuntu will show you a preview of the photos. Choose a location to save your photos to, then click on
Import, and Ubuntu will save your photos to your hard drive.
If Ubuntu does not ask you if it can import the photos:
1.

Open Applications → Graphics → gThumb Image Viewer .

2.

Choose File → Import Photos.

See Section 3, “gThumb Image Viewer” [p. 52]

for more on gThumb.
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2. 3D Graphic Cards
2.1. Introduction to 3D Video Acceleration
Most video hardware should work automatically with Ubuntu. With some types of video hardware,
3D acceleration (which is needed by some games) is not supported automatically, but you may be able
to fix this yourself.
To find out whether 3D acceleration is working, enter in a terminal:
glxinfo | grep rendering

If 3D acceleration is working, the result will be:
direct rendering: Yes

If not, follow these instructions to activate 3D acceleration.

2.2. 3D Nvidia Video Card Driver
No Nvidia Video cards have 3D acceleration enabled automatically with Ubuntu, because the
manufacturer does not release open source drivers. However, it is possible to activate 3D acceleration.
The process depends on which type of video card you have.
• If you have an older TNT, TNT2, TNT Ultra, GeForce1 or GeForce2 card, install the
nvidia-glx-legacy and nvidia-settings packages from the “Restricted” repository (see Chapter 3,
Adding, Removing and Updating Applications [p. 9]).
• If you have a newer card, install the nvidia-glx package from the “Restricted” repository (see
Chapter 3, Adding, Removing and Updating Applications [p. 9]).
To set up the new driver, enter in a terminal:

sudo nvidia-glx-config enable

You can adjust the settings of the new drivers by running nvidia-settings (see the run application
manual [ghelp:user-guide#tools-run-app] for help on how to run an application without
using the menu). If you wish, add a menu entry for this program (see the menu editor manual
[ghelp:user-guide#menu-editor] for help on how to add menu entries).

2.3. 3D ATI Video Card Driver
Many ATI video cards work well with Ubuntu automatically. To check that 3D acceleration works
with your card, see Section 2.1, “Introduction to 3D Video Acceleration” [p. 50]
.
If it doesn’t work:
1.

Install the xorg-driver-fglrx package from the “Restricted” repository (see Chapter 3, Adding,
Removing and Updating Applications [p. 9]).
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2.

To set up the new driver, enter in a terminal:
sudo dpkg-reconfigure xserver-xorg

Agree to automatic detection of your video, and choose the driver fglrx when asked.
Restart the computer for the changes to take effect.
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3. gThumb Image Viewer
gThumb is an advanced image viewer and browser. It has many useful features, such as filesystem
browsing, slide show, image catalogs, web album creation, camera import, image CD burning, batch
file operations and quick image editing features like transformation and color manipulation.
gThumb is included in Ubuntu by default. To start it, choose Applications → Graphics → gThumb
Image Viewer .
For help with gThumb, use the items in its Help menu.
For more advanced photo & image editing, see The GIMP.
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4. The GIMP (Gnu Image Manipulation Program)
The GIMP lets you draw, paint, edit images, and much more. GIMP includes the functionality and
plug-ins of other famous image editing and processing programs.
The GIMP is installed in Ubuntu by default, and can be started by choosing Applications → Graphics
→ GIMP Image Editor .
• GIMP Web site [http://gimp.org/]
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5. Inkscape Vector Graphics Editor
Inkscape is a powerful editor for working with the SVG (Scalable Vector Graphics) format.
1.

Install the inkscape package (see Chapter 3, Adding, Removing and Updating Applications [p.
9]).

2.

To start Inkscape choose Applications → Graphics → Inkscape SVG Vector Illustrator .
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6. Blender 3d Modeller
Blender is an integrated 3d suite for modelling, animation, rendering, post-production, interactive
creation and playback.
1.

Install the blender package (see Chapter 3, Adding, Removing and Updating Applications [p. 9]).

2.

To start Blender choose Applications → Graphics → Blender 3d modeller.
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Chapter 8. Games
Ubuntu comes with 16 games by default, including Aisleriot Solitaire, Gnometris, and Mines.
Explore Ubuntu's Games menu at Applications → Games .
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1. Frozen-Bubble
In Frozen-Bubble you attempt to shoot bubbles into groups of the same color to cause them to pop.
1.

Install the frozen-bubble package from the “Universe” repository (see Chapter 3, Adding,
Removing and Updating Applications [p. 9]).

2.

To start Frozen-Bubble, choose Applications → Games → Frozen-Bubble.
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2. PlanetPenguin Racer
Race Tux, the Linux mascot, down a snow- and ice-covered mountain as quickly as possible, avoiding
the trees and rocks that will slow you down.
Ensure you have hardware accelerated 3D drivers installed for your video card. For more
information see Section 2, “3D Graphic Cards” [p. 50].
1.

Install the planetpenguin-racer package from the “Universe” repository (see Chapter 3, Adding,
Removing and Updating Applications [p. 9]).

2.

To start PlanetPenguin Racer, choose Applications → Games → PlanetPenguin-Racer.
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3. Scorched3D
Scorched3D is a 3D remake of Scorched Earth, an artillery duel game.
Ensure you have hardware accelerated 3D drivers installed for your video card. For more
information see Section 2, “3D Graphic Cards” [p. 50].
1.

Install the scorched3d package from the “Universe” repository (see Chapter 3, Adding,
Removing and Updating Applications [p. 9]).

2.

To start Scorched3D, choose Applications → Games → scorched 3d.
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4. Windows Games
Many games which are available for Windows can be run on Linux through emulators. Examples of
these are Wine and Cedega
1.

For information about Wine, see the Ubuntu wiki [https://help.ubuntu.com/community/Wine].

2.

For information about Cedega, see the Ubuntu wiki
[https://help.ubuntu.com/community/Cedega]
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Chapter 9. Programming
This section contains some basic information for those wishing to use Ubuntu for writing and running
their own programs.
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1. Basic Compilers
Compiling programs requires some packages that are not installed by default. You can install these
all at once by installing the build-essential package (see Chapter 3, Adding, Removing and Updating
Applications [p. 9]).
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2. Java Runtime Environment (1.5)
These instructions are for i386 and amd64 computers only. For PowerPC machines, see
Ubuntu Help Online [https://help.ubuntu.com/community/Java].
At the time of this writing J2SE is at version 5.0 Update 6. This is subject to change. If you
do not see this version on Sun's website, download the newest version displayed.
1.

Go to http://java.sun.com/j2se/1.5.0/download.jsp and click on “Download JRE 5.0 Update 6”.
Do not choose the link with the NetBeans bundle.

2.

You must first accept the licence, then click on “Linux self-extracting file” and Download
jre-1_5_0_06-linux-i586.bin to your hard drive.
If you use an amd64 computer, please replace jre-1_5_0_06-linux-i586.bin with
jre-1_5_0_06-linux-amd64.bin.

3.

Install the java-package package from the “Multiverse” repository (see Chapter 3, Adding,
Removing and Updating Applications [p. 9]).

4.

Make the downloaded file executable. At the command line, change to the directory where you
downloaded the file, and type
chmod +x jre-1_5_0_06-linux-i586.bin

5.

To install JRE, first build an Ubuntu package. Type
fakeroot make-jpkg jre-1_5_0_06-linux-i586.bin

6.

Then install the package you have built:
sudo dpkg -i sun-j2re1.5_1.5.0+update06_i386.deb

7.

To get your system to use Sun Java instead of the open-source (but less functional) GIJ that is
installed by default, run:
sudo update-alternatives --config java

and choose the option that has j2re1.5-sun in it.
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3. Development Tools
These are some of the Integrated Development Environments (IDEs), editors, and other development
tools available for Ubuntu.
• Anjuta [http://anjuta.sourceforge.net/] is an Integrated Development Environment (IDE) for C and
C++.
• Bazaar-NG [http://www.bazaar-ng.org/] is a decentralised version control system used for Ubuntu
development.
• Bluefish [http://bluefish.openoffice.nl/index.html] is a powerful editor for experienced web
designers and programmers.
• Eclipse [http://www.eclipse.org/] is an IDE for Java and other programming languages. It forms the
basis for closed-source programs such as JBuilder.
• Eric [http://www.die-offenbachs.de/detlev/eric3.html] is a fully featured Python and Ruby IDE.
• Glade [http://glade.gnome.org/] is a User Interface designer for building GNOME applications.
• IDLE [http://www.python.org/idle/] is the Python IDE built with the Tkinter GUI toolkit.
• KDevelop [http://www.kdevelop.org/] is a IDE for KDE which supports many programming
languages.
• MonoDevelop [http://www.monodevelop.com/Main_Page] is an IDE for writing mono/.net
applications in C# and other languages.
• NetBeans [http://www.netbeans.org/index.html] is a Java IDE that features support for CVS and a
form builder.
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4. Learning How to Program
4.1. Dive Into Python
Dive Into Python is a book for learning how to program in Python, aimed at programmers with some
previous experience.
• Read Dive Into Python [file:///usr/share/doc/diveintopython/html/toc/index.html]

4.2. PyGTK Tutorial
PyGTK Tutorial is a tutorial on developing with the graphical toolkit often used for developing
Ubuntu applications. It assumes that you have knowledge of Python but not necessarily GTK.
1.

Install the python-gtk2-tutorial package (see Chapter 3, Adding, Removing and Updating
Applications [p. 9]).
You will need to use Synaptic Package Manager to install this package

2.

To access the documentation, visit python-gtk-tutorial
[file:///usr/share/doc/python-gtk2-tutorial/html/index.html].

4.3. Devhelp
Devhelp is an application to read and search all of the documentation that you install.
1.

Install the devhelp package (see Chapter 3, Adding, Removing and Updating Applications [p.
9]).

2.

Choose Applications → Programming → Devhelp.
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Chapter 10. Partitions and Booting
This section contains information about how to change the way that your computer behaves when you
first turn it on, and how to access other operating systems and partitions from Ubuntu.
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1. Graphical Partition Editor
Gparted is a graphical tool to edit disk partitions.
1.

Install the gparted package (see Chapter 3, Adding, Removing and Updating Applications [p. 9]).

2.

You can run the application with System → Administration → Gnome Partition Editor .
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2. Make Windows partitions available from Ubuntu
Windows partitions should be automatically available from any Ubuntu system. If they are not, you
can make them available using the Disks Manager.
1.

Open System → Administration → Disks .

2.

Select the correct hard disk, and click Partitions.

3.

Select the relevant partition, and click Enable.

4.

To unmount the partition, click Disable.
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3. Make Windows partitions automatically available
Windows partitions should be automatically available from Ubuntu. If they are not, the following
procedure will make them automatically available:
1.

Read Section 7.1, “Check disk space usage and view the partition table” [p. 73]

2.

First make a directory where the partition can be made available ("mounted"):

sudo mkdir /media/windows

3.

Next, back up your disk configuration file and open the file in a text editor with administrative
privileges:

sudo cp /etc/fstab /etc/fstab_backup
sudo gedit /etc/fstab

4.

Append the following line at the end of file:
/dev/hda1 /media/windows ntfs umask=0222 0 0

Replace /dev/hda1 with the correct device name for your partition.
If your Windows partition uses the FAT32 filesystem, replace ntfs with vfat in the
above command.
If you have a FAT32 filesystem, it is also safe to allow read-write access. To do this,
change the value of umask to 0000.
5.

Save the edited file (an example [sample/fstab_automountntfs]).

6.

The changes will take effect when the computer is restarted.
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4. Run a system command automatically at startup
Sometimes it can be useful to run a custom command whenever your computer starts up. To do this:
1.

Edit the crontab with administrative privileges (see Chapter 2, Administrative Tasks [p. 8]):
sudo crontab -e

2.

Insert the following line:
@reboot /home/user/command

Replace /home/user/command with the full address to your command.
3.

Save the file and exit.
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5. Change default operating system at boot
To change which operating system starts by default when the computer starts up, edit the grub
configuration file.
1.

Make a backup of the configuration file, and open it in a text editor:
sudo cp /boot/grub/menu.lst /boot/grub/menu.lst_backup
sudo gedit /boot/grub/menu.lst

2.

Find this line:
...
default 0
...

3.

Replace with the following line:
default X

You should replace X with a number, according to the order which your operating
systems appear in the configuration file. You should start counting from 0. For
example, if you wish the default operating system to be the first in the list, replace X
with 0, if you wish the default operating system to be the second in the list, replace X
with 1, and so on.
4.

Save the edited file (an example [sample/menu.list_changedefaultosgrub])
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6. Configure startup services
This requires administrative privileges (see Chapter 2, Administrative Tasks [p. 8]).
1.

Run Services Settings: System → Administration → Services.

2.

Enter your password.

3.

Select the services you want running, then click OK when done.

4.

For greater control over the boot-up services, install the bum from the “Universe” repository
(see Chapter 3, Adding, Removing and Updating Applications [p. 9]), and run it: System →
Administration → Boot-up Manager.
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7. Other Tips
7.1. Check disk space usage and view the partition table
1.

Open System → Administration → Disks .

2.

Select the Harddrive, then the Partitions tab

3.

Each partition will be listed under Partition List, with disk space and mount point.

7.2. List devices
To list mounted devices, in a terminal enter:
mount

The listing shows the device (such as a hard disk partition), the mount point (where you access the
files), the filesystem type and the mount options.
This example shows the hda2 hard disk partition mounted as '/', with the filesystem type ext3. The
partition is mounted with two options, one to allow the device to be read from and wrote to and the
other to remount the device as read only in the event of any errors.
/dev/hda2 on / type ext3 (rw,errors=remount-ro)

To list PCI devices:
lspci

To list USB devices:
lsusb

7.3. Mount/unmount CD/DVD-ROMs manually, and show all hidden and
associated files/folders
Assuming that /media/cdrom0/ is the location of CD/DVD-ROM
To mount a CD/DVD-ROM:

sudo mount /media/cdrom0/ -o unhide

To unmount a CD/DVD-ROM:

sudo umount /media/cdrom0/
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Some printers will be automatically detected by Ubuntu; for those that are not, choose System →
Administration → Printing , then choose Printer → Add Printer.
Some printers need further setup. Search the databases at LinuxPrinting.org
[http://www.linuxprinting.org/] or check the Ubuntu Wiki's Printer page
[https://wiki.ubuntu.com/HardwareSupportComponentsPrinters] for possible information on your
printer.
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Chapter 12. Advanced Desktop
Configuration
This section details some tips for using and customising Ubuntu's desktop environment (called
GNOME), and the file manager (called Nautilus).
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1. Log in automatically when the computer starts
To log in automatically when the computer starts:
1.

Choose System → Administration → Login Window .

2.

Select Security, and turn on Enable Automatic Login.

3.

Choose the account you want to log in as.

This is not recommended for most computers, as it is not secure and may give other people access to
your information.
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2. Open files with administrative privileges from the file
manager
To open files with administrative privileges from the file manager, you need to add a script to
Nautilus.
Opening files with administrative privileges is a security risk. Always ensure that you are
familiar with the file that you are opening.
1.

Open a new file to edit in the relevant directory:
gedit $HOME/.gnome2/nautilus-scripts/Open\ as\ Administrator

2.

Enter these lines in the new file:
for uri in $NAUTILUS_SCRIPT_SELECTED_URIS; do
gksudo "gnome-open $uri" &
done

3.

Save the edited file (an example [sample/nautilus_open_as_administrator])

4.

Make the edited file executable:
chmod +x $HOME/.gnome2/nautilus-scripts/Open\ as\ Administrator

You can now open a file as an administrator by right-clicking on it and choosing Scripts → Open as
Administrator.
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3. Install Extra Fonts
This section describes how to install extra fonts from the Ubuntu archives.
For international fonts, install these packages from the “Universe” repository (see Chapter 3,
Adding, Removing and Updating Applications [p. 9]):
• xfonts-intl-arabic
• xfonts-intl-asian
• xfonts-intl-chinese
• xfonts-intl-chinese-big
• xfonts-intl-european
• xfonts-intl-japanese
• xfonts-intl-japanese-big
• xfonts-intl-phonetic
For Microsoft TrueType core fonts, install the msttcorefonts package from the “Multiverse”
repository (see Chapter 3, Adding, Removing and Updating Applications [p. 9]).
For Ghostscript fonts, install the gsfonts-x11 package (see Chapter 3, Adding, Removing and
Updating Applications [p. 9]).
After installing any new font, rebuild the font information files by entering in a Terminal:
sudo fc-cache -f -v

If you prefer to download individual fonts by hand, you can install them simply and easily by
opening a file manager, and typing fonts:/// into the location bar (see the file manager manual
[ghelp:user-guide#nautilus-location-bar] for how to use the location bar). Then you can simply drag
the font you downloaded into the group of existing fonts.
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4. RAR Archiver
1.

Install the rar package from the “Multiverse” repository (see Chapter 3, Adding, Removing and
Updating Applications [p. 9]).

2.

Run:

sudo ln -fs /usr/bin/rar /usr/bin/unrar

3.

To open a rar file, double click on it.
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5. Advanced Desktop Applets
gDesklets is a system for bringing mini programs (desklets), such as weather forecasts, news tickers,
system information displays, or music player controls, onto your desktop, in a symbiotic relationship
of eye candy and usefulness.
1.

Install the gdesklets and gdesklets-data packages from the “Universe” repository (see Chapter 3,
Adding, Removing and Updating Applications [p. 9]).

2.

Choose: Applications → Accessories → gDesklets

3.

For more information, visit the gDesklets website [http://www.gdesklets.org/]
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6. Hide Recent Documents in the Places menu
To hide Recent Documents from the Places menu, open a terminal and run the command:
chmod 400 ~/.recently-used

To show the menu again, run the command:
chmod 600 ~/.recently-used
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7. Show the Computer, Home, and Trash desktop icons in
GNOME
1.

Open the Configuration Editor, by running the program gconf-editor (see the run application
manual [ghelp:user-guide#tools-run-app] for help on how to run an application without using the
menu).

2.

Choose apps → nautilus → desktop.

3.

Turn on computer_icon_visible, home_icon_visible, and trash_icon_visible. The changes take
effect immediately.
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8. Restart GNOME without rebooting the computer
1.

Save and close all open applications.

2.

Use the Ctrl-Alt-Backspace shortcut keys to restart GNOME.

3.

If Ctrl-Alt-Backspace is disabled, type
sudo /etc/init.d/gdm restart

(See Section 9, “Preventing the Ctrl-Alt-Backspace shortcut keys from restarting X” [p. 84]
to disable Ctrl-Alt-Backspace.)
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9. Preventing the Ctrl-Alt-Backspace shortcut keys from
restarting X
1.

Make a backup copy of your existing /etc/X11/xorg.conf file:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup

2.

Open /etc/X11/xorg.conf for editing:
sudo gedit /etc/X11/xorg.conf

3.

Add the following lines to the end of the file:
Section "ServerFlags"
Option "DontZap" "yes"
EndSection

4.

Save the edited file (an example [sample/xorg.conf_disablectrlaltbackspacegnome]).

5.

The change will take effect the next time you log in to GNOME. If you want the change to
take effect immediately, restart GNOME manually. (See Section 8, “Restart GNOME without
rebooting the computer” [p. 83].)
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